2017年11月16日

Ruby2.4 のインストール

いや〜、もう11月ですかぁ!
年末ですなぁ。
ずいぶん長い事、ここほったらかしにしてますた(汗

なんか今日(11月16日)は、Windows XP が発売された日みたいですね。
2001年、16年前ですな。
わたすも若く幸せな時期ですた、なんて今が不幸な訳ではないですがwww

今回は、Ubuntu16.04 にRuby2.4 入れようとしたら面倒だったので覚書。
apt-get だと2.3までしか入りまへん。
Ubuntuはんは、.bashrc ではなくて .profile なので注意でっせ〜。

[準備]
sudo apt-get -y install git curl g++ make
sudo apt-get -y install zlib1g-dev libssl-dev libreadline-dev
sudo apt-get -y install libyaml-dev libxml2-dev libxslt-dev
sudo apt-get -y install sqlite3 libsqlite3-dev nodejs

[rbenvのインストール]
git clone https://github.com/sstephenson/rbenv.git ~/.rbenv
echo 'export PATH="$HOME/.rbenv/bin:$PATH"' >> ~/.profile
echo 'eval "$(rbenv init -)"' >> ~/.profile
source ~/.profile

[rubyのインストール]
git clone https://github.com/sstephenson/ruby-build.git ~/.rbenv/plugins/ruby-build
rbenv install 2.4.2
rbenv global 2.4.2
rbenv rehash


posted by NERDY at 11:18 | Comment(0) | 技術 | このブログの読者になる | 更新情報をチェックする
この記事へのコメント
コメントを書く
お名前:

メールアドレス:

ホームページアドレス:

コメント:

×

この広告は180日以上新しい記事の投稿がないブログに表示されております。